Jump to content


Custom Search

dieselbot

Member Since 27 Nov 2011
Offline Last Active Mar 27 2013 11:38 PM

Topics I've Started

My Collection

23 March 2013 - 12:35 AM

I have been lurking for a while on this site and decided to make some posts.  I have been into antique toys for the past 30 years or so.  I was mostly into toy cars and trucks.  Once in a while I would stumble across a space toy but didn't take much notice.  A broken Hap Hazard or something like that.  Two or three years ago, I was at an antique show where a antique dealer had an entire tin robot collection for sale at his table.  I was impressed by the design of the early robots and was disappointed that I hadn't taken notice of these toys before.  (All those years wasted staring at Tonka trucks.)  Here is my humble collection from the past 2 or 3 years.  Most of these were found out in the field picking, that is why some are missing some parts.  Chief Smoky is the only reproduction.  I have some flying saucers too that I will post later.  Thanks for lookingAttached File  top coll.jpg   33K   31 downloads.     


X-70 Tulip Help!

22 March 2013 - 11:05 AM

I have only been collecting toy robots for the past 2 or 3 years.  I have been an avid reader of this great site during that time.  I thought I would post with a question. I just acquired an x-70 Tuliphead in the box.  I already had one that is in okay condition but works.  The one in the box will not work.  His lights come on and he makes a wirrring noise, but does not move.  I tried the shaking trick and no luck.  Any ideas on what could be the problem?  He recently was found in the closet of the original owner and had been there for quite some time.  Thanks!